WDCP快速升级到PHP5.5.9及安装soap扩展

对于linux主机,安装WDCP环境,可以方便的可视化管理网站。但是在默认情况下WDCP安装的是php5.1.7版本,这个版本对于安装wordpress已经不合时宜了。原因在于现在好多商业主题和插件对这个环境都不能很好的运行。例如Woocommerce这个电商插件,官方推荐安装php5.4以上版本。所以在安装了WDCP环境后,还要想办法升级到较高的php版本为好。

一、快速升级到php 5.5.9

使用putty软件登陆您的linux主机

执行:

wget http://soft.itbulu.com/wdcp/php_up55.sh

上面一行是下载文件到你的服务器上,输入后回车。再输入下面命令进行升级:

sh  php_up55.sh

WDCP-PHP5.5-1

点y即可,执行完毕,到wdcp后台重启服务器(这个升级过程需要一点时间,请耐心等待)

二、安装SOAP扩展

为什么要安装这个soap呢?这是因为woocommerce插件里的有些支付网关要开启这个才可以用。所以我们只能照办。wdcp默认是没有安装这个东东的(php扩展)。

下载php5.5.9原始包:

wget http://us1.php.net/distributions/php-5.5.9.tar.gz

不一定是上面的网址,只要是可以下载php-5.5.9.tar.gz的都可以。

下载后解压:

tar zxvf php-5.5.9.tar.gz

解压好,进入php-5.5.9目录

cd php-5.5.9

再深入(soap扩展目录中):

cd ext/soap

依次执行命令:

/www/wdlinux/php/bin/phpize

./configure –with-php-config=/www/wdlinux/php/bin/php-config –enable-soap

make

make install

echo ‘extension=soap.so’ >> /www/wdlinux/etc/php.ini

最后重启服务:

service httpd restart

最后说明:上面的文字只为记录一次升级安装过程,以防忘记。也希望对其它网友借鉴。

3条评论

  • 评论者 haiya - 回复

    执行到:“./configure –with-php-config=/www/wdlinux/php/bin/php-config –enable-soap”出错

    出错提示:“configure: error: invalid variable name: –with-php-config”

  • 评论者 haiya - 回复

    ./configure –with-php-config=/www/wdlinux/php/bin/php-config –enable-soap

  • 评论者 haiya - 回复

    花了我两夜时间才找到正解,您的共享非常感谢。但在您共享您的资料时请查看一下正确性

留下回复

您的电邮不会被公布 必填字段标记为*